Vista on MacBook Pro

by Ed on December 17, 2006

Yeah, that’s right. I am actually writing this blog entry in IE7 running on Vista on my MacBook Pro. I’m running under BootCamp. I had also created a Vista environment in Parallels, but seeing that I only have 1G of RAM it was a little pokey at times considering I was trying to compile code 😛 I have to say though that Parallels runs very well otherwise. Very respectable. But I wanted Aero glass and window effects and I wasn’t getting that there. So off to BootCamp I went.

To date, my issues are:

  1. On wake, the machine takes forever before mouse and keyboard input are allowed.
  2. On wake or out of hibernation, the wireless gives out and locks up. I’m generally forced to force-reboot (as even a reboot seems to hang forever… or up to the limit of my patience).
  3. The machine runs pretty hot.
  4. Battery life is not that great.
  5. My trackpad drivers won’t seem to install, so I get no right-click ability without a separate mouse at present.
  6. There’s some ‘Unknown Device’ that wants a driver. I think it’s the keyboard backlight. Sorry, little guy, you’ll have to wait.
  7. It doesn’t seem to dim the screen when it’s set to.
Even with all this, I have to say I’m very pleased with Vista. To the point that I think Mac OS X is looking pretty tired. I dare say I am seriously considering spending the bulk of my computing existence under Vista and not Mac OS X. Those that know me may hunt me down and kill me for saying that, but that’s what the ninja training is for, right?

How did I do this, you ask? Well, I had XP installed under BootCamp, so I just mounted the Vista ISO and did an upgrade. Possibly not the best way to do this, but I didn’t have a real DVD to burn the ISO to at the time (otherwise I would have done a clean install). After the upgrade the only thing that didn’t work was sound. It took me a while to get that to work. I had extracted the drivers from the BootCamp driver installation CD (since it doesn’t run right under Vista) per some instructions on the web and eventually found out I just had to reinstall the SigmaTel driver. Voila. But the trackpad drivers still won’t install for me or something. It works, but I don’t get all the fancy trackpad features that the Apple drivers provide.

Someday, they’ll have solutions for the bulk of my issues. I guess I’ll have to sit tight and wait. I especially hope there’s a good fix in the works for the temperature/battery life issues. Those would prevent me from really adopting this as a full-time portable.

Anyway, perhaps I’ll report more as time goes by and things get fixed… but in the end I’m expecting to get a Lenovo X60 Tablet PC soon, so I might not care so much in a week or so 🙂

P.S. I’d like to point out that my wireless connection works about 98% of the time under Vista, as opposed to the constant annoying drops I get on Mac OS X. So it can’t be the hardware.

{ 4 comments… read them below or add one }

jonathan December 18, 2006 at 10:28 pm

> I’m expecting to get a Lenovo X60 Tablet PC soon

So, I guess we can reopen those tablet bugs for the Engine 😉

Reply

Linda December 20, 2006 at 10:13 pm

Check on the Update website for drivers that you need. They should be making an appearance soon.

Vista is a lot nicer clean installed. ping me if you need more than the process you have. As long as you have a key for it I have no problems getting media to you. It is after all the license that makes it legit.. not the DVD its burned onto 😉

Reply

blogthis January 2, 2007 at 5:57 pm

I see there is a newer verson of bootcamp now version 1.1.2 that claims to add support for everything mentioned above… does it really add everything? And does it work in vista?

Reply

Ed January 2, 2007 at 6:03 pm

Unfortunately no on both counts. 1.1.2 is actually what I had used.

Reply

Cancel reply

Leave a Comment

Previous post:

Next post: